xoops使用「Xoops Protector 防護模組 」模組異常


,

啟用Xoops Protector 防護模組,就會出現下列異常字串。思考很久,突然想起來之前用2.55版本時,自己加了些補充語法。

Notice: Constant PROTECTOR_PRECHECK_INCLUDED already defined in /var/www/html/xoops/xoops_lib/modules/protector/include/precheck.inc.php on line 10

Notice: Constant PROTECTOR_VERSION already defined in /var/www/html/xoops/xoops_lib/modules/protector/include/precheck.inc.php on line 11

結果,比照下列網站,果然出現了訊息。當初舊版需要在「mainfile.php」自行加語法,導致系統一直警告出現雙重定義的訊息。去除後,就可以正常安裝防護模組了!

http://xoops.tn.edu.tw/modules/tadnews/index.php?nsn=84